Some Clients May Experience Delays with Requests on Graphics Plan
Incident Report for Design Pickle
Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 21:07 MDT
Update
We are happy to report that the team is back to full capacity after the storms!
Posted Nov 01, 2022 - 21:06 MDT
Identified
Some clients on our Graphics Plan may be experiencing delays with requests due to the storms in the Philippines. We are keeping an eye on the situation and impact.
Posted Nov 01, 2022 - 11:36 MDT
This incident affected: Design Team.