Typhoon Vamco: possible delays to production.
Incident Report for Design Pickle
Resolved
Great news! All affected teammates are safe and sound. We are also back at 100% production capacity. Thank you for your kind thoughts, words, and prayers.
Posted Nov 16, 2020 - 06:02 MST
Update
We are continuing to monitor for any further issues.
Posted Nov 13, 2020 - 07:12 MST
Update
Typhoon Vamco has passed through the Philippines. All of our teammates are safe and accounted for. We are currently working at 95% capacity and hope to be back to 100% shortly.
Posted Nov 13, 2020 - 06:54 MST
Update
We are continuing to monitor for any further issues.
Posted Nov 12, 2020 - 10:49 MST
Update
Typhoon Vamco has now hit the Philippines causing several power and internet outages mainly in the Metro Manila area. Production delays are possible. We will continue to monitor the situation and keep you updated.
Posted Nov 12, 2020 - 06:08 MST
Update
Typhoon Vamco has now hit the Philippines causing several power and internet outages mainly in the Metro Manila area. Production delays are possible. We will continue to monitor the situation and keep you updated.
Posted Nov 12, 2020 - 06:01 MST
Monitoring
Typhoon Vamco is approaching the Philippines and may impact our Design Team based there.

If your designer is based in the Philippines, this may result in a production delay. We will continue to monitor the situation and keep you updated.
Posted Nov 11, 2020 - 09:58 MST
This incident affected: Design Team.