Some Users May Experience Issues Purchasing Plans
Incident Report for Design Pickle
Resolved
This incident is resolved.
Posted Mar 22, 2022 - 14:05 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 22, 2022 - 11:55 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 22, 2022 - 10:30 MDT
Identified
The issue has been identified and a potential fix will go out shortly.
Posted Mar 22, 2022 - 10:29 MDT
This incident affected: API and Design Pickle Website.