We're back up and have solved the issue. Sorry for the inconvenience.
Incident Report for Design Pickle
Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 14:36 MDT
Investigating
We currently are experiencing some issues with users being unable to log into DPP. We hopefully will have it up as soon as possible. Thanks for your patience!
Posted Apr 26, 2021 - 20:15 MDT
This incident affected: Design Pickle Website and Design Team.