Some clients may be experiencing a slowdown in processing e-mail requests
Incident Report for Design Pickle
Resolved
Request creation via email is caught up and the issue has been resolved.
Posted Feb 24, 2023 - 15:34 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2023 - 15:27 MST
Update
We are still investigating the issue.
Posted Feb 24, 2023 - 14:02 MST
Update
We have identified the cause of the slowdown in processing email requests and they are now caught up. We are continuing to monitor the system.
Posted Feb 24, 2023 - 10:54 MST
Investigating
We are currently investigating the issue.
Posted Feb 24, 2023 - 10:04 MST
This incident affected: Design Request Email.