The site is currently down -- we are investigating and will hopefully have it up as soon as possible
Incident Report for Design Pickle
Resolved
We're back up and have solved the issue. Sorry for the inconvenience.
Posted Nov 23, 2020 - 11:16 MST
Investigating
We are currently investigating this issue.
Posted Nov 23, 2020 - 07:21 MST
This incident affected: API, Design Pickle Website, and Zapier Integration.